TLS 1.2 Update

 
 

As you may be aware, new PCI DSS requirements states that all systems must disable early TLS by June 30th, 2018. In preparation for this requirement, we plan on disabling TLS 1.0 and 1.1 on June 26th, 2018 on all of our online stores.

Please also verify your computers are up-to-date as old operating systems and browsers will no longer be able to access our websites after the disablement date. These browsers/systems include, but are not limited to:

·       Windows XP 

·       Internet Explorer 7 on Windows Vista 

·       Internet Explorer 8-10 on Windows 7 

Please note that roughly 99% of shoppers will not be affected by this change. For instructions on how to update your browser, click here.